kris25

my 74 super starts up fine and stays running at idle for 20min or so then she starts to die unless i give it gas.she drives fine until i stop at a light/stop sing then she dies.i drove the other night for 45min then got off an exit an stopped and the she died.this happen the first time when i installed a set of offset deck hinges.does any one have any ideas?

Quote 0 0
BugMan

Sounds to me like carb adjustment.  Warm the engine well and the readjust the carb.  Offset hinges may also have something to do with that due to the fact that it's getting more air now.

Quote 0 0
kris25

i just tried adjusting the carb that did not work.any thing else it could be.

Quote 0 0
ryen74

You might want to advance your timing a little too. What does it idle at when it does idle?

Ryen
"Arizona dreamin'"
Quote 0 0
fatalifeaten
What kind of carb is it? 34 pict 3? check the idle cutoff solenoid, it may be on the way out. Also check and make sure you're not vaporizing the gas in the fuel line and vapor locking the engine once it warms up. Installing a decklid standoff kit should have zero impact on this. My guess is that idle shutoff. It's fine until the metal warms up, then it shorts out because something's expanded and causing it to flake. Could also be something else electrically related for the same reason. Once the car warms up and everything gets hot, something in the idle circuit is shorting or failing. I had a similar problem on my 34 pict 3 and replacing that idle cutoff solenoid cured my ills.
Daily Driven Dubz Phoenix AZ Family


'66 Deluxe
'63 Deluxe ragtop
'61 Deluxe
Quote 0 0
kris25

it was the air jet

Quote 0 0
fatalifeaten
the air correction jet?

what was wrong w/it?

Daily Driven Dubz Phoenix AZ Family


'66 Deluxe
'63 Deluxe ragtop
'61 Deluxe
Quote 0 0
kris25

i guess thats what its called.the jet was clogged my friend said.

Quote 0 0